>
Shared Top Border

Shared Left Border
Welcome, Guest. Please login or register.
Did you miss your activation email?
June 28, 2017, 03:17:17 AM

Home Help Search Calendar Login Register


+  Offroad Exchange - MOD
|-+  Dodge 4x4's
| |-+  94- Up Ram/Dakota Board
| | |-+  Popcorn sound from exhaust and loss of all power after highway driving ?
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] Go Down Print
Author Topic: Popcorn sound from exhaust and loss of all power after highway driving ?  (Read 1710 times)
TerryC
Newbie
*
Offline Offline

Posts: 1


« on: August 25, 2015, 10:11:02 AM »

Hey guys I'm new to this site I'm hoping someone can help me I have a 2002 dodge ram 1500 slt crew cab with a 5,9 when I drive the truck in the city never have a problem but when I take the truck on the highway after driving for a while the truck will loose power and start making a popcorn sound from the exhaust and won't have enuff power to keep driving I thought it was the cat I changed it and it seemed to ok driving it on the back roads but then after driving it harder for a bit  it did the same popping and loss of power thing does any1 know what is making this happen ? I was thinking maybe the injectors r not working right my buddy thinks it could b fuel pump I have just put a bunch of money into the truck and can't afford to just keep changing things till I find the problem so any help would b great thanks
Logged
Bill Cooke
Administrator
Hero Member
*****
Offline Offline

Gender: Male
Posts: 3314


I drive a Dodge, My wife drives... me crazy!


« Reply #1 on: August 30, 2015, 11:25:14 AM »

Have you tried to pull any trouble codes? You can google how to check the codes and what they all mean. That should help narrow it down. A fuel pump or filter could very well be the problem. I'd lean towards the filter as it seems to be under load or higher flow that you have the problem. Could also be a bad O2 sensor. A bad injector would cause a rough idle.

Any mechanical or electrical part will throw a code. The fuel filter will not. You would just get a "O2 sensor out of range" sort of code as the engine runs too lean. That lean miss could be the source of your problem.

If the O2 sensor goes bad your engine goes into limp home mode where it dumps a ton of fuel into the engine and uses some default settings that will get you off the road safely, but very slowly. Also could explain the popping and loss of power.

Hope this helps. If you find it please post what it was. Might help the next guy

Bill
Logged

Jeep is hobby, Dodge is a sickness!
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Shared Bottom Border

Home - Table of Contents  - Contact Us

Copyrighted© 1998--2017 The Offroad Exchange. All rights reserved. 
Jeep is a registered Trademark of Chrysler. 
Offroad Exchange is not affiliated with Chrysler, Jeep, Or Dodge.